ClearTax Ingestion experiencing degraded performance

Incident Report for ClearTax EInvoicing

Resolved

The issue with Ingestion has been resolved. Thanks for your patience.
Posted Aug 21, 2025 - 22:41 IST

Investigating

ClearTax Ingestion is currently experiencing degraded performance and it's possible that Users are experiencing slowness while uploading their data to ClearTax E-Invoicing products. Our engineers are working on resolving the issue at the earliest. We will update the status in the next 30 minutes. Apologies for any inconvenience caused.
Posted Aug 21, 2025 - 19:36 IST
This incident affected: ClearTax E-Invoicing & E-waybill (Ingestion).